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Introduction 
The MOXstick is a USB interface for excitation and readout of resistive sensors. It is especially tuned 

to the requirements of Metal Oxide Semiconductor gas sensor. 

 

The USB stick is divided into a large part containing acquisition and excitation electronics, and a 

smaller back part containing the sensor socket. This back part can be split from the main board and 

connected using the available connector pads and a flat five way cable. This provides freedom for 

sensor placement, in case it needs to be mounted remotely (for instance in a sensing chamber). 

The MOXstick is directly recognized by Windows without the need for any driver installations. 

The universal sensor socket allows the connection of a large number of sensors from different 

manufacturers. This is accomplished with different sensor orientations when connecting to the 

available pins. Care must be taken to ensure the validity of the sensor connection, by observing the 

provided on-board connection summary, as described in paragraph Sensor connection. 

The JLMlog SP software provides a simple interface for heater voltage programming and data 

logging. Sensor resistance, heater current and heater voltage are recorded and stored to a text file 

immediately. The software can operate a multitude of MOXsticks simultaneously. See paragraph 

JLMlog SP software for details.  
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Sensor connection 
At the back portion of the MOXstick PCB-board there is a universal sensor connector to connect the 

sensors (see figure below).  

 

The sensors will typically be mounted on the universal connector by use of pin headers, or 

alternatively directly soldered into it. Note that connection of the Figaro TGS 82x sensors has two 

possible positions which are equally valid. A comprehensive summary table of compatible sensor 

models is provided in the next page. 

 

Break-out board detaching 
Take especial care to cut both sides of the cutting line 

first. Small diagonal cutting pliers can be used for that 

purpose. Once both sides of the cutting line are cut at 

the right place, the board can be finally detached by 

breaking the rest with your fingers.  
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Sensor Compatibility table 

Manufacturer Model Description / use (according to manufacturer) 

FIGARO 

TGS 2610 LP-Gas detection 
TGS 2611 Methane detection 
TGS 2442 CO detection -pulsed sensor 
TGS 2444 detection of Ammonia 
TGS 2620 detection of solvent vapors 
TGS 2600 detection of air contaminants 
TGS 2104 detection of gasoline exhaust gases 
TGS 2201 detection of gasoline exhaust gases 
TGS 2602 detection of air contaminants 
TGS 813 Combustible gases1 
TGS 826 Ammonia1 
TGS 8xx 1 

Applied sensor 
 

AS-MLC CO sensor - low power 
AS-MLN NO2 sensor - low power 
AS-MLK CH4 sensor - low power 

AS-MLV VOC sensor - low power 

UST 

GGS1000 family2 especially suitable for leak detection of combustible gases 
GGS2000 family2 sensor for CO-, hydrogen- und alcohol, low cross sensitivity to CH4 methane 
GGS3000 family2 sensor for hydrocarbons, especially suitable for stationary observation of LEL 
GGS4000 family2 selective sensor for ammonia, with low cross sensitivity to CH4, CO, H2and humidity 
GGS5000 family2 sensor especially sensitive to nitric oxide and ozone 
GGS6000 family2 sensor for hydrogen, with low cross sensitivity to CH4, humidity and alcohol 
GGS7000 family2 sensor for detection of NO2 - smouldering fires 

FIS 

SB-95-12 CO and CH4 sensor 
SB-11A HC detection 
SP-11 HC detection 
SB-12A Methane detection 

SP-12A Methane detection 
SB-15 LP-Gas detection 
SP-15A LP-Gas detection 
SB-500 CO detection -pulsed sensor 
SB-19 Hydrogen detection 
SP-19 Hydrogen detection 
SB-30 Alcohol detecion 
SP-31 Alcohol and solvents detection 
SB-41 Refrigerants detection 
SP-41 Refrigerants detection 
SB-42A Refrigerants detection 
SP-42A Refrigerants detection 
SP-53A Ammonia detection (high conc) 
SP-53B Ammonia detection (low conc) 
SP3-AQ2 Indoor air quality (VOCs) 
SP3S-AQ2 Indoor air quality (VOCs) 
SB-AQ1 Indoor air quality 

  

                                                           
1 Available upon request 
2 Please contact us for recommendations on heater resistance and chip size selection. 
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The JLMlog SP software 

Installation 
The JLMlog SP software is delivered as a setup program. Please install the software by running the 

setup program and following the directions in the setup program. You will need administrator rights 

to install the software. 

After install the software you may wish to check for updates. The software contains an automatic 

check for updates which gives you the option to download and install new versions directly from 

inside the software. More information can be found under paragraph Setup Tab below. 

Prerequisites 

The JLMlog SP software and the USB stick will work under Windows XP or higher. After plugging in 

the USB stick for the first time, Windows will identify the stick. Windows already contains the 

necessary drivers and will configure the drivers automatically. 

Software Overview 
The JLMlog SP software provides very complete functionality in the shape of a very compact software 

interface, its main functionalities are: 

- Sensor resistance, sensor current, Sensor voltage, Heater resistance, Heater voltage, Heater 

current, Heater power viewing and (long term) logging functions. 

- MOXstick heater voltage cycle definition and programming 

- Graphical sensor feature selection 

- Elementary signal preprocessing functions 

- Graphical selection of training dataset 

- Principal Component Analysis (PCA) calculation and display 

- Real-time updating of PCA plots using newly acquired data 

The software functions are accessible through four different tabs in the main interface window: 

Measurement, Analysis, Analysis graph and Setup Tabs. 

Starting JLMlog SP 
Please connect the USB stick to the computer before starting the software. The software will 

automatically detect the USB stick. If more than one MOXstick are connected, one plot line will 

appear for each of them in the data plots. 

All settings in the software are automatically stored when closing the software. When starting the 

software the last settings are loaded. 

Important: In order to save any measurement data, the log file has to be 

activated before taking the measurements! 

The firmware on the USB stick has to match the software. The software will upgrade the firmware on 

the USB stick if it detects an older version of the firmware on the USB stick.  
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Using JLMlog SP 
The main software window is divided in four tabs.  

The measurement tab 
It consists a graph area and an user input area on top. The top area of two main parts. The upper 

area contains all controls to set operation modes and parameters for the measurement. 

 

Graphs can be zoomed by dragging a box into the desired area. Double clicking or dragging a box 

from lower right to upper left will undo the zoom. Holding the right mouse button allows to shift a 

zoomed graph. 

The top part allows to enter the name of the log file, activate datalogging (using the checkbox) and 

actually starting the measurement by clicking into the START button (see at the end Logging Data). 

The Max Points parameter controls the number of measurements shown in the graph.  

In order to avoid high computing load due to drawing of complex graphs, it is advised to choose a low 

number of graphs and Max Points. 

The Setup tab 
The different MOXsticks plugged into your PC will show up in the setup tab identified by their serial 

numbers. The overall measurement cycle interval is shown on top (this number cannot be lower than 

the longest programmed cycle for a sensor, plus a short ms of margin) Each of them can be 

individually configured by clicking on Edit while the correct stick is selected in the bottom window.  
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The Active checkbox for the Telnet Server allows to enable and disable the telnet server (see below). 

The Edit window allows to change the settings of a given sensor, its naming (Sensor), the maximum 

allowed voltage to the heater Maximum Heater Voltage, the expected Resistance Range to measure, 

and the Sensor readout voltage (Sensor Voltage). This last voltage is precisely the voltage drop that 

will be applied across the sensor sensing resistance, if self-heating of the sensor is an issue, lower 

settings should be used. Please select Sensor voltage, Resistance Range and Maximum Heater 

Voltage according to the specifications of the sensor manufacturer. 
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The subframe named Cycle shows the heater cyling definition tool. Each step has a set duration (Step 

Interval), the duration of every heater step is set in number of Step Interval units, and the total 

number of cycle intervals is defined in Count. For each cycle interval, the Duration and the Heater 

Voltage can be set. A graph in the bottom right shows a summary of the programmed heater 

excitation waveform. The Edit tab allows saving and loading the programmed settings for the 

parameters, and the cycle. At the end of each cycle interval, a measurement point is taken. 

The changes are applied instantaneously, when the edit window is closed. If you want to keep a 

previous setup, make use of the ‘save’ and ‘load’ buttons, as you will have no ‘undo’ or ‘cancel’ 

options. 

Attention: Do not set heater voltages in excess of the recommendations for the 

sensor device, as this will damage the sensor! 

 

The Analysis Tab 

Currently, PCA analysis is supported by JLMlog SP. The Analysis Tab will soon incorporate other 

analysis options, selectable under the Algorithm menu.  
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In order to add features to the Analysis, the button Add needs to be clicked. A new window appears 

showing the different measurements for each Cycle Interval and for each sensor. It is then possible to 

add each measurement to the analysis, applying a pre-processing algorithm (Algorithm menu). 
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After the features have been selected, a training or reference set needs to be defined in order to 

compute the PCA scores. The subframe Reference Data contains the Add button for this purpose. 

Once the button is clicked, a new window appears showing the features extracted for the current 

dataset. 

 

Right clicking in the points of interest will show a blue selection bar indicating that the point has been 

selected as reference data point. 
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The Analysis Graph Tab 
Once features and reference data has been selected, the Analysis results are shown in the Analysis 

Graph Tab. It is possible to view the PCA Scores, PCA Loadings, and the Features. The lines 

connecting the points show trajectories in time. Reference data are shown as diamond-shaped blue 

points, and the general data as yellow round points. The larger red point indicates the latest 

measurement. The Max Points selection allows to show only the last 50, 100, 250, 500, 1000 or 2000 

data points of the current acquisition. During the acquisition of measurement data it is advisable to 

choose a low number of data points, to avoid constant redrawing of complex graphs. 
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Logging data 
Measurement data can automatically be logged to a text file. This option needs to be activated 

before the measurement is started.  

The following box contains an example of a log file. The first lines are the header of the log file. The 

first line contains a text to identify the file as a JLMlog file.  

Lines containing non measurement data (e.g. header) always start with #. 

All subsequent lines contain measurement data. The general format is tab delimited floating point. 

The decimal sign is always the point ‘.’.  
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If the file already exists at measurement start, a new file will be generated with the same name plus 

a number string appended or incremented. 

Telnet Server 
The program has a built in telnet server, that allows to communicate with the program from other 

software and computers. Measurements can be started and stopped and parameters can be read. 

Adjustment of parameters has to be done via the JLMlogSP software and cannot be done via telnet. 

If the telnet server is active, the current IP address and port, where the server can be reached, is 

shown in the status line. If a client is connected to the server the IP address of the client is shown 

too. 

The telnet server listens on port 23 and accepts 4 commands: 

V<Enter> Send software version 
Returns the a string in the format:  

# programname buildversion 

# JLMlogSP 1.3.4854.62283 

C<Enter> Send all measurement settings 
Sends the complete header as in a log file containing all measurement parameters 

S<Enter> Start the measurement 
Starts a measurement. The complete header with all measurement parameters is sent first. Then the 

measurement data is sent, one line per stick and cycle. The format is the same as for the log file. 

X<Enter> Stop the measurement 
Stops a measurement 

#>>>>>>>>>>> 
#JLMlogSP 1.3 1.3.4854.62283 
#Started 16.04.2013 17:18:19 41380.7210582407 
#Interval [ms] 250 
#List 
#Stick Id Stick Sensor Sensor Gain Resistance Step Interval Step Count
 [Duration/HeaterVoltage]... 
#0 1J6548180C000900 TGS2600 1000 25 4 [1/1100] [1/1400] [1/900]
 [1/1700] 
#1 1J6548181B001100 AS-MLV 21677.89453125 25 3 [1/1600] [1/2600] [1/2100] 
#ListEnd 
#Stick Id Sensor Voltage [V] Sensor Current [µA] Heater Voltage [V] Heater Current [mA] 
#<<<<<<<<<<< 
0 0.099239 5.96141E-10 1.28396 3.46604E-5 0.0993631 -6.2126E-8
 1.57417 2.20515E-5 0.099239 1.88762E-7 1.09637 -3.16621E-6  
1 1.00033 2.79601E-6 1.59947 0.0144741 1.00039 7.75457E-5 2.5971 0.0192104
 1.00033 9.51332E-5 2.10063 0.0150812 
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Main menu items 
The File -> Load Log File menu item imports the data from an old log file. Only data from MOXsticks, 

that are connected to the PC are imported! 

The File -> Clear Data menu item removes current measurement data from memory. 

The File -> Exit closes the software. 

The Help -> Manual menu item opens this manual in a pdf reader (must be installed independently). 

The Help -> About menu item opens following dialog: 

 

When opening this dialog, the program will check for new versions of the software via internet. If a 

newer version is found, the Install button will be enabled. If you click the Install button the setup 

program for the newest version is retrieved and started.  

If Automatically check for updates during program start is enabled, the software will check for new 

versions via the internet whenever the program is started. If a new version is found, this dialog will 

appear automatically. 


